const regex = /([+-]?) *([ij]?) *(\d+)[.,]?(\d*)([ij])?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([+-]?) *([ij]?) *(\\d+)[.,]?(\\d*)([ij])?', 'g')
const str = `-15 + 8.14i
-15+8.14j
-15 j 8,14
bad line here
+23.4-j24
-35+42.3j
+24i
+2.342j
24.523-i 432,52`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}