import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([+-]?) *([ij]?) *(\\d+)[.,]?(\\d*)([ij])?";
final String string = "-15 + 8.14i\n"
+ "-15+8.14j\n"
+ "-15 j 8,14\n"
+ "bad line here\n"
+ "+23.4-j24\n"
+ "-35+42.3j\n"
+ "+24i\n"
+ "+2.342j\n"
+ "24.523-i 432,52";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}