$re = '/([+-]?) *([ij]?) *(\d+)[.,]?(\d*)([ij])?/';
$str = '-15 + 8.14i
-15+8.14j
-15 j 8,14
bad line here
+23.4-j24
-35+42.3j
+24i
+2.342j
24.523-i 432,52';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);