#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)-->\h+\d\d:\d\d:\d\d,\d+\R"
Local $sString = "1" & @CRLF & _
"00:00:01,05 --> 00:00:04,64" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"2" & @CRLF & _
"00:00:05,02 --> 00:00:07,18" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"3" & @CRLF & _
"00:00:07,81 --> 00:00:11,03" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"4" & @CRLF & _
"00:00:11,04 --> 00:00:15,92" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"5" & @CRLF & _
"00:00:16,35 --> 00:00:17,11"
Local $sSubst = "$0-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)