import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-->\\h+\\d\\d:\\d\\d:\\d\\d,\\d+\\R";
final String string = "1\n"
+ "00:00:01,05 --> 00:00:04,64\n\n\n"
+ "2\n"
+ "00:00:05,02 --> 00:00:07,18\n\n\n"
+ "3\n"
+ "00:00:07,81 --> 00:00:11,03\n\n\n"
+ "4\n"
+ "00:00:11,04 --> 00:00:15,92\n\n\n"
+ "5\n"
+ "00:00:16,35 --> 00:00:17,11";
final String subst = "$0-";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}