const regex = /-->\h+\d\d:\d\d:\d\d,\d+\R/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-->\\h+\\d\\d:\\d\\d:\\d\\d,\\d+\\R', 'gm')
const str = `1
00:00:01,05 --> 00:00:04,64
2
00:00:05,02 --> 00:00:07,18
3
00:00:07,81 --> 00:00:11,03
4
00:00:11,04 --> 00:00:15,92
5
00:00:16,35 --> 00:00:17,11`;
const subst = `$0-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);