// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)-->\h+\d\d:\d\d:\d\d,\d+\R").unwrap();
let string = "1
00:00:01,05 --> 00:00:04,64
2
00:00:05,02 --> 00:00:07,18
3
00:00:07,81 --> 00:00:11,03
4
00:00:11,04 --> 00:00:15,92
5
00:00:16,35 --> 00:00:17,11";
let substitution = "$0-";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}