using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-->\h+\d\d:\d\d:\d\d,\d+\R";
string substitution = @"$0-";
string input = @"1
00:00:01,05 --> 00:00:04,64
2
00:00:05,02 --> 00:00:07,18
3
00:00:07,81 --> 00:00:11,03
4
00:00:11,04 --> 00:00:15,92
5
00:00:16,35 --> 00:00:17,11";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}