import Foundation
let pattern = #"-->\h+\d\d:\d\d:\d\d,\d+\R"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1
00:00:01,05 --> 00:00:04,64
2
00:00:05,02 --> 00:00:07,18
3
00:00:07,81 --> 00:00:11,03
4
00:00:11,04 --> 00:00:15,92
5
00:00:16,35 --> 00:00:17,11
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)