use strict;
my $str = '1
00:00:01,05 --> 00:00:04,64
2
00:00:05,02 --> 00:00:07,18
3
00:00:07,81 --> 00:00:11,03
4
00:00:11,04 --> 00:00:15,92
5
00:00:16,35 --> 00:00:17,11';
my $regex = qr/-->\h+\d\d:\d\d:\d\d,\d+\R/mp;
my $subst = '$0-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";