# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\{\{[\s\n]*(?!['\s\n])(.*')[\s\n]*(\|[\s\n]+translate)\b/{{ '$1 $2/gm;t' <<< "anyText' | translate
other text or tags{{ anyText' | translate
{{
anyText' | translate
anyText'
| translate
Strings Not To Match:
'anyText' | translate
<other text or tags>{{ 'anyText' | translate
'anyText'
| translate"