re = /\{\{[\s\n]*(?!['\s\n])(.*')[\s\n]*(\|[\s\n]+translate)\b/m
str = 'anyText\' | translate
other text or tags{{ anyText\' | translate
{{
anyText\' | translate
anyText\'
| translate
Strings Not To Match:
\'anyText\' | translate
<other text or tags>{{ \'anyText\' | translate
\'anyText\'
| translate'
subst = '{{ \'$1 $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result