import Foundation
let pattern = #"\{\{[\s\n]*(?!['\s\n])(.*')[\s\n]*(\|[\s\n]+translate)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
anyText' | translate
other text or tags{{ anyText' | translate
{{
anyText' | translate
anyText'
| translate
Strings Not To Match:
'anyText' | translate
<other text or tags>{{ 'anyText' | translate
'anyText'
| translate
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{{ '$1 $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)