use strict;
my $str = 'anyText\' | translate
other text or tags{{ anyText\' | translate
{{
anyText\' | translate
anyText\'
| translate
Strings Not To Match:
\'anyText\' | translate
<other text or tags>{{ \'anyText\' | translate
\'anyText\'
| translate';
my $regex = qr/\{\{[\s\n]*(?!['\s\n])(.*')[\s\n]*(\|[\s\n]+translate)\b/mp;
my $subst = '{{ \'$1 $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";