using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\{[\s\n]*(?!['\s\n])(.*')[\s\n]*(\|[\s\n]+translate)\b";
string substitution = @"{{ '$1 $2";
string input = @"anyText' | translate
other text or tags{{ anyText' | translate
{{
anyText' | translate
anyText'
| translate
Strings Not To Match:
'anyText' | translate
<other text or tags>{{ 'anyText' | translate
'anyText'
| translate";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}