$re = '/\{\{[\s\n]*(?![\'\s\n])(.*\')[\s\n]*(\|[\s\n]+translate)\b/m';
$str = 'anyText\' | translate
other text or tags{{ anyText\' | translate
{{
anyText\' | translate
anyText\'
| translate
Strings Not To Match:
\'anyText\' | translate
<other text or tags>{{ \'anyText\' | translate
\'anyText\'
| translate';
$subst = "{{ '$1 $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;