import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{[\\s\\n]*(?!['\\s\\n])(.*')[\\s\\n]*(\\|[\\s\\n]+translate)\\b";
final String string = "anyText' | translate\n\n"
+ "other text or tags{{ anyText' | translate\n\n"
+ "{{ \n"
+ "anyText' | translate\n\n"
+ "anyText'\n"
+ " | translate \n"
+ "Strings Not To Match:\n\n"
+ "'anyText' | translate\n\n"
+ " <other text or tags>{{ 'anyText' | translate\n\n"
+ "'anyText'\n"
+ " | translate";
final String subst = "{{ '$1 $2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}