package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z0-9 \t\r_]*[A-Za-z][A-Za-z0-9 \t\r_]*$`)
var str = `ameya123
ameya
AMeya12
Ameya_123
Ameya_ 123
123
_
$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}