re = /^[A-Za-z0-9 \t\r_]*[A-Za-z][A-Za-z0-9 \t\r_]*$/m
str = 'ameya123
ameya
AMeya12
Ameya_123
Ameya_ 123
123
_
$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end