$re = '/^[A-Za-z0-9 \t\r_]*[A-Za-z][A-Za-z0-9 \t\r_]*$/m';
$str = 'ameya123
ameya
AMeya12
Ameya_123
Ameya_ 123
123
_
$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);