#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^(?!.*\bno\b.*\b(text|sample text)\b)(?!.*\b(text|sample text)\b .*not).+$)"
Local $sString = "should not match: first sentence with no and sample text " & @CRLF & _
"" & @CRLF & _
"should not match: second with a text but also a not" & @CRLF & _
"" & @CRLF & _
"should not match: third has a no, a text and a not" & @CRLF & _
"" & @CRLF & _
"should match: fourth alone is what is neeeded with just text" & @CRLF & _
"" & @CRLF & _
"should match: keep putting line here no" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")