import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^(?!.*\\bno\\b.*\\b(text|sample text)\\b)(?!.*\\b(text|sample text)\\b .*not).+$)";
final String string = "should not match: first sentence with no and sample text \n\n"
+ "should not match: second with a text but also a not\n\n"
+ "should not match: third has a no, a text and a not\n\n"
+ "should match: fourth alone is what is neeeded with just text\n\n"
+ "should match: keep putting line here no\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}