using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^(?!.*\bno\b.*\b(text|sample text)\b)(?!.*\b(text|sample text)\b .*not).+$)";
string input = @"should not match: first sentence with no and sample text
should not match: second with a text but also a not
should not match: third has a no, a text and a not
should match: fourth alone is what is neeeded with just text
should match: keep putting line here no
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}