import Foundation
let pattern = #"(^(?!.*\bno\b.*\b(text|sample text)\b)(?!.*\b(text|sample text)\b .*not).+$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
should not match: first sentence with no and sample text
should not match: second with a text but also a not
should not match: third has a no, a text and a not
should match: fourth alone is what is neeeded with just text
should match: keep putting line here no
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)