use strict;
my $str = 'should not match: first sentence with no and sample text
should not match: second with a text but also a not
should not match: third has a no, a text and a not
should match: fourth alone is what is neeeded with just text
should match: keep putting line here no
';
my $regex = qr/(^(?!.*\bno\b.*\b(text|sample text)\b)(?!.*\b(text|sample text)\b .*not).+$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}