# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r'(^(?!.*\bno\b.*\b(text|sample text)\b)(?!.*\b(text|sample text)\b .*not).+$)'
test_str = ("should not match: first sentence with no and sample text \n\n"
"should not match: second with a text but also a not\n\n"
"should not match: third has a no, a text and a not\n\n"
"should match: fourth alone is what is neeeded with just text\n\n"
"should match: keep putting line here no\n\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur'' to prefix the regex and u"" to prefix the test string and substitution.