const regex = new RegExp('(^(?!.*\\bno\\b.*\\b(text|sample text)\\b)(?!.*\\b(text|sample text)\\b .*not).+$)', 'gm')
const str = `should not match: first sentence with no and sample text
should not match: second with a text but also a not
should not match: third has a no, a text and a not
should match: fourth alone is what is neeeded with just text
should match: keep putting line here no
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}