package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<value>[\s\S]*?(([0-2]?[0-9]?[0-9]\.){3}([0-2]?[0-9]?[0-9]))[\s\S]*?<\/value>`)
var str = `<value>activemq:tcp://192.168.0.172:61616?transport.useInactivityMonitor=false</value>
<value>192.168.0.172</value>`
var substitution = "{$1 $2 $3}"
fmt.Println(re.ReplaceAllString(str, substitution))
}