import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<value>[\\s\\S]*?(([0-2]?[0-9]?[0-9]\\.){3}([0-2]?[0-9]?[0-9]))[\\s\\S]*?<\\/value>";
final String string = "<value>activemq:tcp://192.168.0.172:61616?transport.useInactivityMonitor=false</value>\n"
+ "<value>192.168.0.172</value>";
final String subst = "{$1 $2 $3}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}