// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<value>[\s\S]*?(([0-2]?[0-9]?[0-9]\.){3}([0-2]?[0-9]?[0-9]))[\s\S]*?<\/value>").unwrap();
let string = "<value>activemq:tcp://192.168.0.172:61616?transport.useInactivityMonitor=false</value>
<value>192.168.0.172</value>";
let substitution = "{$1 $2 $3}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}