#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^.*?)\.(.*?)(_\d$)"
Local $sString = "3052503155104.Bourjois_FDTAirMat_01_1" & @CRLF & _
"3052503155104.Bourjois_FDTAirMat_01_2" & @CRLF & _
"3052503155104.Bourjois_FDTAirMat_01_3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")