const regex = /(^.*?)\.(.*?)(_\d$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^.*?)\\.(.*?)(_\\d$)', 'gm')
const str = `3052503155104.Bourjois_FDTAirMat_01_1
3052503155104.Bourjois_FDTAirMat_01_2
3052503155104.Bourjois_FDTAirMat_01_3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}