$re = '/(^.*?)\.(.*?)(_\d$)/m';
$str = '3052503155104.Bourjois_FDTAirMat_01_1
3052503155104.Bourjois_FDTAirMat_01_2
3052503155104.Bourjois_FDTAirMat_01_3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);