// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^.*?)\.(.*?)(_\d$)").unwrap();
let string = "3052503155104.Bourjois_FDTAirMat_01_1
3052503155104.Bourjois_FDTAirMat_01_2
3052503155104.Bourjois_FDTAirMat_01_3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}