import re
regex = re.compile(r"(^.*?)\.(.*?)(_\d$)", flags=re.MULTILINE)
test_str = ("3052503155104.Bourjois_FDTAirMat_01_1\n"
"3052503155104.Bourjois_FDTAirMat_01_2\n"
"3052503155104.Bourjois_FDTAirMat_01_3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")