#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xm)\{(.|\s)*\}"
Local $sString = "test string is with lot of text and this part {" & @CRLF & _
" "List": [{" & @CRLF & _
" "ID": "175114"," & @CRLF & _
" "Number": "28992"" & @CRLF & _
" }]" & @CRLF & _
"} and more text goes here after the valid JSON"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")