using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{(.|\s)*\}";
string input = @"test string is with lot of text and this part {
""List"": [{
""ID"": ""175114"",
""Number"": ""28992""
}]
} and more text goes here after the valid JSON";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}