import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{(.|\\s)*\\}";
final String string = "test string is with lot of text and this part {\n"
+ " \"List\": [{\n"
+ " \"ID\": \"175114\",\n"
+ " \"Number\": \"28992\"\n"
+ " }]\n"
+ "} and more text goes here after the valid JSON";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}