package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{(.|\s)*\}`)
var str = `test string is with lot of text and this part {
"List": [{
"ID": "175114",
"Number": "28992"
}]
} and more text goes here after the valid JSON`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}