re = /\{(.|\s)*\}/xm
str = 'test string is with lot of text and this part {
"List": [{
"ID": "175114",
"Number": "28992"
}]
} and more text goes here after the valid JSON'
# Print the match result
str.match(re) do |match|
puts match.to_s
end