$re = '/\{(.|\s)*\}/xm';
$str = 'test string is with lot of text and this part {
"List": [{
"ID": "175114",
"Number": "28992"
}]
} and more text goes here after the valid JSON';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);