// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?xm)\{(.|\s)*\}").unwrap();
let string = "test string is with lot of text and this part {
\"List\": [{
\"ID\": \"175114\",
\"Number\": \"28992\"
}]
} and more text goes here after the valid JSON";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}