# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d\d\d\d)(\d\d)(\d\d)_(\d\d)(\d\d)(\d\d)(\S+)/$1-$2-$3_$4.$5.$6$7/gm;t' <<< "
20220716_165615-IMG_1234.jpg
20220717_102742-IMG_1235.jpg
20220717_193212-IMG_1236.jpg"