use strict;
my $str = '
20220716_165615-IMG_1234.jpg
20220717_102742-IMG_1235.jpg
20220717_193212-IMG_1236.jpg';
my $regex = qr/(\d\d\d\d)(\d\d)(\d\d)_(\d\d)(\d\d)(\d\d)(\S+)/mp;
my $subst = '$1-$2-$3_$4.$5.$6$7';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";