// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d\d\d\d)(\d\d)(\d\d)_(\d\d)(\d\d)(\d\d)(\S+)").unwrap();
let string = "
20220716_165615-IMG_1234.jpg
20220717_102742-IMG_1235.jpg
20220717_193212-IMG_1236.jpg";
let substitution = "$1-$2-$3_$4.$5.$6$7";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}