$re = '/(\d\d\d\d)(\d\d)(\d\d)_(\d\d)(\d\d)(\d\d)(\S+)/m';
$str = '
20220716_165615-IMG_1234.jpg
20220717_102742-IMG_1235.jpg
20220717_193212-IMG_1236.jpg';
$subst = "$1-$2-$3_$4.$5.$6$7";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;