#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d\d\d\d)(\d\d)(\d\d)_(\d\d)(\d\d)(\d\d)(\S+)"
Local $sString = "" & @CRLF & _
"20220716_165615-IMG_1234.jpg" & @CRLF & _
"20220717_102742-IMG_1235.jpg" & @CRLF & _
"20220717_193212-IMG_1236.jpg"
Local $sSubst = "$1-$2-$3_$4.$5.$6$7"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)