import re
regex = re.compile(r"(\d\d\d\d)(\d\d)(\d\d)_(\d\d)(\d\d)(\d\d)(\S+)", flags=re.MULTILINE)
test_str = ("\n"
"20220716_165615-IMG_1234.jpg\n"
"20220717_102742-IMG_1235.jpg\n"
"20220717_193212-IMG_1236.jpg")
subst = "$1-$2-$3_$4.$5.$6$7"
result = regex.sub(subst, test_str)
if result:
print(result)