package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d\d\d\d)(\d\d)(\d\d)_(\d\d)(\d\d)(\d\d)(\S+)`)
var str = `
20220716_165615-IMG_1234.jpg
20220717_102742-IMG_1235.jpg
20220717_193212-IMG_1236.jpg`
var substitution = "$1-$2-$3_$4.$5.$6$7"
fmt.Println(re.ReplaceAllString(str, substitution))
}