# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!<[^>]*)\s(?<![^>]*<)(?=[^\s]*$)/ /g;t' <<< "My custom text with <a href=\"#\">a link<a/><span style=\"color: red;\">.</span>"